Openwrt : opkg 한꺼번에 꾸러미 판올림

굳이 할 필요는 없겠지만.. 그래도 또 해보고 싶은게 인지상정. 아니, 我之通情 이려나.

opkg list-upgradable | cut -f 1 -d ' ' | xargs opkg upgrade 

수시 판올림의 문제점에 대해서는 알고는 있어야겠지만, 외부 저장소를 쓰다보니 공간은 펑펑남고, 아까운 느낌도 들어서 그냥 해보기로.

** 펌웨어 판올림 후에는!

펌웨어 판올림 이후에, 뭔가 (나는) 알 수없는 이유로 꾸러미가 최신판으로 바뀌지 않는 현상이 있다.
이런 오류가 나기도 한다.

satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-core:
kernel (= 4.14.195-1-fa00c1231ac7d7840ec6ffe62dcad926)

그럴 땐, 강제 옵션을 넣어주면 된다.

opkg list-upgradable | cut -f 1 -d ' ' | xargs opkg upgrade --force-depends

이래서 아무 문제가 없는 건진.. ^^

안녕하세요. 글 남겨주셔서 고맙습니다.